作业帮 > 英语 > 作业

杭电的acm的题A+B for Input-Output Practice (IV)

来源:学生作业帮 编辑:灵鹊做题网作业帮 分类:英语作业 时间:2024/06/28 09:14:09
杭电的acm的题A+B for Input-Output Practice (IV)
Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases.Each test case contains a integer N,and then N integers follow in the same line.A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line,and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
杭电的acm的题A+B for Input-Output Practice (IV)
学习一下输入输出就好,欢迎交流.#include<stdio.h>

int main()
{
    int n,x,sum;
    while(scanf("%d",&n)&&n!=0)
    {
        sum = 0;
        while(n--)
        {
            scanf("%d",&x);
            sum+=x;
        }
        printf("%d/n",sum);
    }
    return 0;
}